Discuz! 官方站

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 4863|回复: 12

[求助] 求助:论坛无法访问,后台控制面板也无法登录

[复制链接]
发表于 2021-3-29 11:01:08 | 显示全部楼层 |阅读模式
DNSPod 新春好礼 - 域名低至 1 元起,代金券大礼包暖心送!
求助:论坛无法访问,后台控制面板也无法登录




我是一个菜鸟,请大侠们支招!
谢谢!







本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
发表于 2021-3-29 15:05:48 | 显示全部楼层
本帖最后由 evilvoy 于 2021-3-29 18:00 编辑

搬家调整适合的php 版本 ?。。。。如果不是搬家导致看看改了啥文件
回复

使用道具 举报

发表于 2021-3-29 16:43:23 | 显示全部楼层
环境有没有改什么配置?Discuz! 版本号提供一下。
回复

使用道具 举报

 楼主| 发表于 2021-3-29 22:51:30 | 显示全部楼层
老周部落 发表于 2021-3-29 16:43
环境有没有改什么配置?Discuz! 版本号提供一下。

我也不记得版本好了。我查了一下是2014年2月份安装的。如果您有时间,我可以进到server -- SQL数据库,把屏幕分享给您,万分感谢!
回复

使用道具 举报

发表于 2021-3-30 14:29:26 | 显示全部楼层
maplevoice 发表于 2021-3-29 22:51
我也不记得版本好了。我查了一下是2014年2月份安装的。如果您有时间,我可以进到server -- SQL数据库,把 ...

看 source/discuz_version.php
回复

使用道具 举报

 楼主| 发表于 2021-3-31 08:56:37 | 显示全部楼层
老周部落 发表于 2021-3-30 14:29
看 source/discuz_version.php

非常感谢耐心指导。得到信息如下:

*      [Discuz!] (C)2001-2099 Comsenz Inc.
*      This is NOT a freeware, use is subject to license terms
*
*      $Id: discuz_version.php 34300 2013-12-30 06:26:07Z hypowang $
*/

if(!defined('IN_DISCUZ')) {
        exit('Access Denied');
}

if(!defined('DISCUZ_VERSION')) {
        define('DISCUZ_VERSION', 'X3.1');
        define('DISCUZ_RELEASE', '20140101');
        define('DISCUZ_FIXBUG', '30000000');
}

?>

我今天发现Wordpress也不能打开了,不知道是不是一样的问题:
Your PHP installation appears to be missing the MySQL extension which is required by WordPress.
我要升级PHP吗?

谢谢。
回复

使用道具 举报

发表于 2021-3-31 13:38:57 | 显示全部楼层
maplevoice 发表于 2021-3-31 08:56
非常感谢耐心指导。得到信息如下:

*      [Discuz!] (C)2001-2099 Comsenz Inc.

PHP的MySQL扩展未安装,安装好了两个问题都能解决。
回复

使用道具 举报

 楼主| 发表于 2021-4-1 08:29:15 | 显示全部楼层
老周部落 发表于 2021-3-31 13:38
PHP的MySQL扩展未安装,安装好了两个问题都能解决。

谢谢老周部落,网站建设我是门外汉,没有学过任何课程。还得麻烦您细致讲解如何安装扩展。
https://blog.csdn.net/u012767761/article/details/71616534 这个网站讲到如何安装扩展,但是看不懂。我再找找看有没有更详细的介绍。再次感谢!!
回复

使用道具 举报

 楼主| 发表于 2021-4-1 10:49:13 | 显示全部楼层
老周部落 发表于 2021-3-31 13:38
PHP的MySQL扩展未安装,安装好了两个问题都能解决。

我刚刚去go daddy后台把PHP扩展版本从7.4改成5.6就好了。但是这个PHP老版本能一直用吗?我还是得赶紧学点PHP, SQL相关知识才行啊。
回复

使用道具 举报

发表于 2021-4-3 15:19:31 | 显示全部楼层
maplevoice 发表于 2021-4-1 10:49
我刚刚去go daddy后台把PHP扩展版本从7.4改成5.6就好了。但是这个PHP老版本能一直用吗?我还是得赶紧学点 ...

X3.1 不支持 PHP 7 ,需要用 X3.4 自带的升级程序升级到 X3.4 才能支持 PHP 7 。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

腾讯云自营「网站建设」全新上线!仅需1元,即可快速体验企业官网、电商网站的海量精美模版

小黑屋|Discuz! 官方站 ( 粤B2-20090059-165 )star

GMT+8, 2021-4-14 02:53

Powered by Discuz! X3.4

Copyright © 2001-2019 Tencent Cloud.

快速回复 返回顶部 返回列表