Discuz! 官方站

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 5023|回复: 11

PHP 8.0 发布了

[复制链接]
发表于 2020-11-25 13:49:46 | 显示全部楼层 |阅读模式
但 Discuz! X3.4 不能在 PHP 8.0 中运行。
发表于 2020-11-26 04:52:45 | 显示全部楼层
PHP 8.0 不是为了Discuz! X3.4而开发,用不到,正常。
回复

使用道具 举报

 楼主| 发表于 2020-11-27 10:00:42 | 显示全部楼层
allthebest 发表于 2020-11-26 04:52
PHP 8.0 不是为了Discuz! X3.4而开发,用不到,正常。

Discuz! 应该为 Php 8.0 更新。
回复

使用道具 举报

发表于 2020-11-27 21:05:29 | 显示全部楼层
ohtc 发表于 2020-11-27 02:00
Discuz! 应该为 Php 8.0 更新。

Discuz x 3.4 更新也不可能支持 PHP8.0。另外,没一个Discuz x 3.4 插件与第三方模版、扩展支持 PHP8.0。
回复

使用道具 举报

发表于 2020-12-1 21:30:20 | 显示全部楼层
5.6 或者7.0就可以php那么高版本没用,没用。一点用没有。。。。。
回复

使用道具 举报

发表于 2020-12-1 21:31:25 | 显示全部楼层
ohtc 发表于 2020-11-27 10:00
Discuz! 应该为 Php 8.0 更新。

你要那么高版本有什么用!!!!!版本高了反而出现的问题也多。
回复

使用道具 举报

 楼主| 发表于 2020-12-1 23:52:45 | 显示全部楼层
??~?? 发表于 2020-12-1 21:31
你要那么高版本有什么用!!!!!版本高了反而出现的问题也多。

你的想法很搞笑,如果高版本没用,Php 为什么要更新?你说这些是因为你不知道 Php 8 在性能上的提升,在安全层面的提升,在功能上的提升。
回复

使用道具 举报

 楼主| 发表于 2020-12-1 23:56:11 | 显示全部楼层
allthebest 发表于 2020-11-27 21:05
Discuz x 3.4 更新也不可能支持 PHP8.0。另外,没一个Discuz x 3.4 插件与第三方模版、扩展支持 PHP8.0。

保持更新是一个程序不可避免的事情,除非 Discuz 不想办了,否则它迟早会兼容新版本的 Php,只是未必是 Discuz 3.4 来兼容,3.4 估计会被 Discuz 抛弃。
回复

使用道具 举报

发表于 2020-12-2 00:27:48 | 显示全部楼层
ohtc 发表于 2020-12-1 15:56
保持更新是一个程序不可避免的事情,除非 Discuz 不想办了,否则它迟早会兼容新版本的 Php,只是未必是 D ...

没一个Discuz x 3.4 插件与第三方模版、扩展支持 PHP8.0。Discuz x 3.4 不会支持PHP8.0。
回复

使用道具 举报

发表于 2020-12-5 18:33:04 | 显示全部楼层
ohtc 发表于 2020-12-1 23:52
你的想法很搞笑,如果高版本没用,Php 为什么要更新?你说这些是因为你不知道 Php 8 在性能上的提升,在 ...

但是很多插件不支持怎么解决呢!!!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

腾讯云自营「网站建设」全新上线!仅需1元,即可快速体验企业官网、电商网站的海量精美模版

小黑屋|Discuz! 官方站 ( 粤B2-20090059-165 )star

GMT+8, 2021-1-21 10:13 , Processed in 0.059648 second(s), 13 queries , Gzip On.

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表