Discuz! 官方站

 找回密码
 立即注册

QQ登录

只需一步,快速开始

DNSPod 新春好礼 - 域名低至 1 元起,代金券大礼包暖心送!
搜索
查看: 1965|回复: 15

[求助] discuz! X3.4升级X3.5时,出现Discuz! Database Error,(附错误截图)请问如何解决

[复制链接]
发表于 2020-6-22 11:04:30 | 显示全部楼层 |阅读模式
DNSPod 新春好礼 - 域名低至 1 元起,代金券大礼包暖心送!
本帖最后由 weifunet 于 2020-6-22 11:22 编辑


discuz! X3.4升级X3.5时运行update.php升级过程出现此错误。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
发表于 2020-6-22 11:50:08 | 显示全部楼层
你没认真看升级说明啊?update.php怎么能用这个呢
回复

使用道具 举报

 楼主| 发表于 2020-6-22 11:58:57 | 显示全部楼层

换成这个
update_adult.php
升级时出现这个
!!!!
是不是Mysql数据库必须要5.7.30版本才行呀!

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

发表于 2020-6-22 12:02:13 | 显示全部楼层
weifunet 发表于 2020-6-22 11:58
换成这个
update_adult.php
升级时出现这个

现在是的多少?
回复

使用道具 举报

 楼主| 发表于 2020-6-22 12:08:02 | 显示全部楼层
现在是Mysql5.6,看升级程序里面最低要求是5.3就行的呀!
回复

使用道具 举报

发表于 2020-6-22 12:11:06 | 显示全部楼层
weifunet 发表于 2020-6-22 12:08
现在是Mysql5.6,看升级程序里面最低要求是5.3就行的呀!

尝试修复下数据库 提示你了  
回复

使用道具 举报

 楼主| 发表于 2020-6-22 12:11:56 | 显示全部楼层


数据表升级中就出现这个了...


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

发表于 2020-6-22 12:13:47 | 显示全部楼层
weifunet 发表于 2020-6-22 12:11
数据表升级中就出现这个了...

修复下表 另外友情提示 不建议直接用3.5,现在不保证任何东西不变化,包括表结构。
回复

使用道具 举报

 楼主| 发表于 2020-6-22 12:54:08 | 显示全部楼层
qlshhlh 发表于 2020-6-22 12:13
修复下表 另外友情提示 不建议直接用3.5,现在不保证任何东西不变化,包括表结构。

你说的对,直接用3.5风险比较大,我也只是用3.4试着升级一下3.5看看服务器支持不支持,用Discuz!X3.5的话,数据库版本还是5.7.30及以上版本合适!
回复

使用道具 举报

发表于 2020-6-22 19:21:21 | 显示全部楼层
3.5升级后,数据库表结构有一定的变动,升级方案和之前的不一样了。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

腾讯云知识产权服务特惠,商标快速注册仅需270元、版权登记低至299元,更有全场2700元代金券大礼包可领,可免费咨询专业顾问。

小黑屋|Discuz! 官方站 ( 粤B2-20090059-165 )star

GMT+8, 2020-7-15 04:14

Powered by Discuz! X3.3

Copyright © 2001-2019 Tencent Cloud.

快速回复 返回顶部 返回列表