Discuz! 官方站

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 924|回复: 2

[分享] Discuz! 插件安装文件.xml注释

[复制链接]
发表于 2015-3-8 12:45:15 | 显示全部楼层 |阅读模式
<?xml version="1.0" encoding="ISO-8859-1"?>
<root>
        <item id="Title"><![CDATA[Discuz! Plugin]]></item>
        <item id="Version"><![CDATA[X3,X3.1,X3.2]]></item>  插件安装支持版本。
        <item id="Time"><![CDATA[2014-09-09 09:00]]></item>
        <item id="From"><![CDATA[Discuz! Board (http://www.discuz.so)]]></item>
        <item id="Data">
                <item id="plugin">
                        <item id="available"><![CDATA[1]]></item>
                        <item id="adminid"><![CDATA[0]]></item>
                        <item id="name"><![CDATA[WonderMedia]]></item>  插件名称。
                        <item id="identifier"><![CDATA[Wonder_MediaV9]]></item>  插件开发者唯一标识符。
                        <item id="description"><![CDATA[WonderMedia 原创横排美化插件]]></item>  插件功能介绍说明。
                        <item id="datatables"><![CDATA[]]></item>
                        <item id="directory"><![CDATA[WonderMediaV9/]]></item>  插件目录名称,最后面需带“/”;路径基于source/plugin/……
                        <item id="copyright"><![CDATA[WonderMedia]]></item>   插件版权信息、作者。
                        <item id="version"><![CDATA[1.0]]></item>   插件版本号。
                        <item id="__modules">
                                …………插件模块信息
                                </item>
                        </item>
                </item>
                <item id="version"><![CDATA[X3,X3.1,X3.2]]></item>   插件兼容性版本设置,是否支持多disucz多版本。多版本应以半角字符“,”分割。
                <item id="license"><![授权协议文本]]></item>   授权协议内容,支持BBCODE代码,不支持html。
                <item id="intro"><![插件介绍说明文本]]></item>   支持BBCODE代码,不支持html。
                <item id="installfile"><![install.php]]></item>   安装文件名,非必须,可选择使用。
                <item id="uninstallfile"><![uninstall.php]]></item>   卸载文件名,非必须,可选择使用。
                <item id="upgradefile"><![upgrade.php]]></item>   更新升级文件名,非必须,可选择使用。
                </item>
</root>



评分

1

查看全部评分

发表于 2015-3-8 12:48:21 | 显示全部楼层
<item id="Version"><![CDATA[X3,X3.1,X3.2]]></item>  插件安装支持版本。
注释改为 插件开发Discuz!版本比较合适
回复

使用道具 举报

 楼主| 发表于 2015-3-8 12:49:43 | 显示全部楼层
流泪的星星 发表于 2015-3-8 12:48
插件安装支持版本。
注释改为 插件开发Discuz!版本比较合适

嗯嗯!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Discuz! Q 3.0 全新来袭 助力变现

小黑屋|Discuz! 官方站 ( 粤B2-20090059-165 )star

GMT+8, 2021-10-22 18:14

Powered by Discuz! X3.4

Copyright © 2001-2019 Tencent Cloud.

快速回复 返回顶部 返回列表