设为首页收藏本站

Discuz! 官方站

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 362|回复: 5

[求助] Discuz3.3升级3.4开启全站HTTPS导致QQ互联不能用

[复制链接]
发表于 2019-4-13 17:52:12 | 显示全部楼层 |阅读模式
本帖最后由 满天星2000 于 2019-4-13 17:55 编辑

1. 升级都正常
2. HTTPs全站也都能用
3. 微信登录插件也能登录
4. QQ互联报错,无法登录:
首页选择【使用qq账号登录】,选择自己当前登录的QQ,然后报错如下:
抱歉,当前存在网络问题或服务器繁忙,详细错误:connect_error_code_0,错误代码:,请您稍候再试。谢谢。


尝试方法1: 已经在后台应用中将QQ互联更新到2.0了,还是报同样的错误
尝试方法2:在后台应用--应用中心,绑定的网站里面,也已经将URL从http更新为https,并认证通过。

另外,以前3.2、3.3都一直在使用云平台,新版3.4貌似没有云平台功能了,连那个云平台诊断都已经删掉了

其他错误:
应用下就4个插件,只有微信能用,qq报错,其他2个纵横搜索和腾讯分析,均提示文件不存在。

另外:升级的版本是直接从git clone  https://gitee.com/ComsenzDiscuz/DiscuzX
版本信息显示为:Discuz! X3.4 Git,理论上应该是最新版了
但是打开应用中心首页,还提醒我:友情提示:您的 Discuz! X3.4 有新版本 Release 20190206,点击此处更新

发表于 2019-4-13 17:58:24 | 显示全部楼层
自己申请独立ID 和 KEY 就可以用了 如果申请了独立ID和KEY 出现问题 可以加我QQ交谈 有偿解决
回复

使用道具 举报

发表于 2019-4-13 19:45:42 | 显示全部楼层
X3.4没有云平台,所以如果你用的以前云平台的QQ互联,里边的网站是http的,而现在网站用的https,那QQ互联就无法使用。
云平台和应用中心没关系
回复

使用道具 举报

发表于 2019-4-14 09:47:52 | 显示全部楼层
  升级3.4后卸载云平台,自行配置QQ互联的APPKEY和回调域名,但升级上来的好像不需要重新申请呢!
回复

使用道具 举报

 楼主| 发表于 6 天前 | 显示全部楼层
  1. X3.4 自身升级

  2. 直接覆盖文件即可
  3. 从 X3.2、X3.3 升级

  4. 备份数据库
  5. 建立文件夹 old,旧程序除了 data , config, uc_client, uc_server 目录以外的程序移动进入 old 目录中
  6. 上传 X3.4 程序(压缩包中 upload 目录中的文件), 如上传时候提示覆盖目录,请选择“是”
  7. 如果您不再需要云平台相关插件,请上传安装包 utility 目录中的 clearcloud.php 到论坛 install 目录,执行后将会把云平台相关应用进行降级操作
  8. 升级完毕,进入后台,更新缓存,并测试功能 X3.4 其中的QQ互联功能已升级为允许使用QQ互联官方的 appid,新站点必须到 http://connect.qq.com/ 申请,升级上来的站点不受影响
复制代码


完全按照官方说明做的,然而并没有什么卵用……
应该是某个地方有问题的,试了一下用clearcloud.php删除了云平台,更新各种数据,还是一样的结果。
回复

使用道具 举报

发表于 6 天前 | 显示全部楼层
可能是哪里没做好。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|Comsenz ( 粤B2-20090059-165 )  star

GMT+8, 2019-4-22 02:31

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表