设为首页收藏本站

Discuz! 官方站

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 966|回复: 4

[已完结] 建议应用中心放开php5.2强制兼容的规定

[复制链接]
发表于 2017-6-23 09:26:20 | 显示全部楼层 |阅读模式
咨询求助
网站 URL: 隐藏内容
网站 ID: 隐藏内容
应用URL: 隐藏内容
联系方式: 隐藏内容
是否有php5.2强制兼容的规定, 应该是有吧,如果不强制那么是好事。

Discuz也应该与时俱进啦。
php5.2不支持命名空间太坑了,导致很多sdk都没法使用,基本上都需要人工去改sdk或者重写。重复造轮子。另外5.2不安全、性能低。

希望插件能放开强制php5.2的兼容。可以强制说明文档醒目的备注。

另外,强制兼容,应该对用户影响不大吧。 以前老插件php5.2版本的zend加密应该没几个插件了吧。
发表于 2017-6-23 09:54:22 | 显示全部楼层
然而还有很多站用的是5.2
回复

使用道具 举报

发表于 2017-6-23 10:09:45 | 显示全部楼层
+1
5.2实在太古老了。
回复

使用道具 举报

发表于 2017-6-23 10:31:21 | 显示全部楼层
然而还有很多站用的是5.2
回复

使用道具 举报

发表于 2017-6-24 00:15:09 | 显示全部楼层
使用了命名空间的自己显著位置注明PHP版本要求就是了
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|Comsenz ( 粤B2-20090059-165 )  

GMT+8, 2017-9-21 16:52

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表