设为首页收藏本站

Discuz! 官方站

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 76897|回复: 3

请升级您的QQ互联到OAuth2.0版本

[复制链接]
发表于 2015-6-12 17:13:41 | 显示全部楼层 |阅读模式
由于QQ互联官方接口的升级,原有 OAuth1.0 版本将接口无法正常使用,凡是出现错误或 QQ 互联官方提示的 Discuz! 论坛必须开启并升级 QQ 互联到 OAuth2.0 版本

要支持 OAuth2.0,请按照以下步骤执行升级工作:
1、要您服务器的 PHP 能正常访问 HTTPS 远程页面,这需要确保您服务器的 PHP 拥有扩展 php_curl、php_openssl 并开启 HTTPS 的访问功能,并且无防火墙等系统级拦截情况,如您不了解如何开启此功能,请联系您的服务商解决
2、确保您 Discuz! 的版本是否是 Discuz! 3.1 及以上版本,低于此版本的请升级
3、下载本帖所附的附件,更新到 QQ互联插件目录(source/plugin/qqconnect),然后访问下方 URL 升级到 OAuth2.0 版本
http://yourwebsite/plugin.php?id=qqconnect:oauth_switch

(http://yourwebsite 请自行替换为您的论坛地址)
4、测试 QQ 互联是否正常,正常后删除 oauth_switch.inc.php 文件

OAuth2.0 升级脚本
qqconnect_oauth_switch.zip (645 Bytes, 下载次数: 13654)
发表于 2017-4-28 14:36:28 | 显示全部楼层
本帖最后由 blues⊙pig 于 2017-4-28 14:39 编辑

DZ X2.0 QQ不能登陆,是不是已经关闭了DZ X2.0的QQ互联?
DZ X2.0 在不升级论坛程序的情况下如何解决这个问题?仍然有大量的DZ X2.0在运行......
回复

使用道具 举报

发表于 2017-5-6 20:10:35 | 显示全部楼层
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|Comsenz ( 粤B2-20090059-165 )  star

GMT+8, 2018-9-23 08:35

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表