设为首页收藏本站

Discuz! 官方站

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 20147|回复: 66

[修改] 新浪微博Xweibo插件版V1接口升级到v2接口

[复制链接]
发表于 2012-8-28 21:40:10 | 显示全部楼层 |阅读模式
本帖最后由 风乱流年 于 2012-9-18 15:56 编辑

新浪通知
尊敬的开发者您好,自8月27日起,微博开放平台将禁止“累计使用人数小于1000”的应用使用V1接口。请相关应用的开发者及时将应用切换至V2接口。V2接口文档请点击:http://t.cn/zWEIweJ 新版接口迁移指南请点击:http://t.cn/zWEIwei 感谢您对新浪微博开放平台的支持!

可是新浪只是停用了接口并没有发布Xweibo插件的升级包,也就是说很多网站的微博登录将不能使用。出错特征:出错啦   来源app_key错误 或  系统内部错误,请稍后重试

现在把我改好的接口文件发出来:
我的环境是xweibo 版本2.1.5   discuz x版本 2.0最新的discuz x 2.5未测试
1.下载附件,解压到xwb/lib目录下
2.修改xwb/common.cfg.php文件找到define('XWB_API_URL',  'http://api.t.sina.com.cn/'); 改为如下内容

// 微博 api url(保留)
define('XWB_API_URL',  'http://api.t.sina.com.cn/');
//define('XWB_API_VERSION', '1.0a');
/*oauth版本*/
define('XWB_API_VERSION', '2.0');
/*接口*/
define('XWB_API_URL_20',  'https://api.weibo.com/');
/*认证*/
define('XWB_API_AUTH_URL',  'http://api.weibo.com/');
/*微博域名*/
define('XWB_API_WEB_URL',  'http://weibo.com/');
3.修改xwb/lib/core.class.php文件找到XWB_plugin::O('weibo')修改为

if (XWB_API_VERSION == "2.0") {
            return XWB_plugin::O('weibo2_0');
} else {
            return XWB_plugin::O('weibo');
}
这样就升级完成了,可随时换成1.0a或换成2.0
注:由于V2接口使用了https协议所以要打开php模块php_openssl

代码为个人制作共享,不对BUG和产生的系统问题负责。升级前备份 pre_xwb_bind_info   pre_xwb_bind_thread   pre_xwb_session 三张表。
xwb_lib.rar

2012-08-29 上面第2点写错了,应该是 修改xwb/common.cfg.php文件找到define('XWB_API_URL',  'http://api.t.sina.com.cn/');改为如下内容 ,已修正。
2012-08-29  由于用到了xweibo版本2.1.5的xwb_util_json类,所以用2.1版本的请先升级,升级地址
http://bbs.x.weibo.com/viewthread.php?tid=135868&extra=page%3D1
原文下载附件 http://blog.linuxphp.org/archives/1565/

最新打包信息请到http://www.discuz.net/thread-3095519-1-1.html 查看



评分

1

查看全部评分

发表于 2012-8-28 21:45:55 | 显示全部楼层

众里寻他千百度,蓦然回首在这里!
回复

使用道具 举报

发表于 2012-8-28 22:24:31 | 显示全部楼层
正为此问题困饶!!!!!!!!!!!!!!!!!!!!!!!!
回复

使用道具 举报

发表于 2012-8-28 22:31:40 | 显示全部楼层
我的是X2.0最新的版本2.1
我没有找到你这句啊“define('XWB_API_VERSION', '1.0a');”
回复

使用道具 举报

发表于 2012-8-28 22:44:32 | 显示全部楼层
你好,有两个问题:

1.我的环境是X2最新版的登陆插件2.1,不知道您说的2.1.5是在哪升级啊?
我的xwb/common.cfg.php文件找不到define(\'XWB_API_VERSION\', \'1.0a\');这句~~~

2.我在使用的虚拟主机不支持HTTPS,是不是就不能使用V2接口了啊?

谢谢~
回复

使用道具 举报

发表于 2012-8-29 00:26:23 | 显示全部楼层
碰到跟楼上相同的问题了,求解答!
回复

使用道具 举报

发表于 2012-8-29 07:50:18 | 显示全部楼层
能不能联系到你本人?搞不定这个登入啊
回复

使用道具 举报

发表于 2012-8-29 08:21:23 | 显示全部楼层
回复

使用道具 举报

发表于 2012-8-29 09:10:18 | 显示全部楼层
我尝试了一下网站就打不开。。。太神奇了
回复

使用道具 举报

发表于 2012-8-29 12:53:07 | 显示全部楼层
{:soso_e845:}           我的是X2.0最新的版本2.1我没有找到你这句啊“define('XWB_API_VERSION', '1.0a');”
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|Comsenz ( 粤B2-20090059-165 )  

GMT+8, 2018-2-23 04:48

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表