Discuz! 官方站

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 169697|回复: 169

[安装升级] Discuz! X系列任意版本到 Discuz! X2.5 升级图文教程

[复制链接]
发表于 2011-11-8 17:14:46 | 显示全部楼层 |阅读模式
说明:本文档用于帮助您将原有的 Discuz! X 系列任意版本升级到 Discuz! X2.5 正式版本。

一、升级前的准备
1、请您仔细阅读升级前的注意事项(非常重要)。
2、下载最新程序并关闭站点。
3、备份数据库。
4、站点程序及其附件的备份。
5、上传最新程序到您的站点目录覆盖旧程序。
6、设置相关目录的文件属性,以便数据文件可以被程序正确读写。

以上几点的详细说明请参考http://www.discuz.net/thread-2250465-1-4.html

注意:在升级前一定要确保之前的 UCenter 是 UCenter 1.6.0 版本,如果之前安装的 UCenter Server 没有进行升级操作的话,一般为 1.5.1 或者1.5.2 版本,您需要首先升级 Ucenter 到 1.6.0 版本, 否则安装程序会提示错误,无法继续。

二、升级站点数据(以虚拟主机上的升级步骤做演示)

1、上传 utilities 目录中的 update.php 文件到 install 目录中,并确保 install/data 中的 sql 文件完整。

2、在浏览器中运行 http://www.domain.com/install/update.php 开始升级(其中 http://www.domain.com 为你的站点访问地址)


点击“准备完毕,升级开始”链接进行升级。

3、开始升级



升级过程全部为自动,无需人工操作,您只要耐心等待就可以了。

4、数据库结构删除

您可以选择删除与标准数据库相比是多余的的数据表和字段,您也可以忽略多余的表和字段。



5、完成升级
点击“直接进入下一步”请确认是否要恢复默认风格,如下图所示:



如果选择“是”您的站点将恢复站点默认风格。然后将自动更新缓存,等待缓存更新完毕后,站点升级完成。



6、如果您之前的站点已经开通了QQ 互联,需要单独执行一下 QQ 互联的升级程序,具体操作如下:
1)下载附件中的文件包,然后解压缩直接上传到站点的 ./install/ 下。
2)如果您是从 Discuz! 7.2 版本升级到 Discuz! X2.5 版本请先修改如下代码,填写正确的升级前的Discuz! 7.2数据库配置:

  1. // 注意:请站长手工修改一下Discuz!7.2 数据库配置
  2. $config['1']['dbhost'] = 'localhost';// 服务器地址
  3. $config['1']['dbuser'] = 'root';// 用户
  4. $config['1']['dbpw'] = 'root';// 密码
  5. $config['1']['dbcharset'] = 'gbk';// 字符集
  6. $config['1']['pconnect'] = '0';// 是否持续连接
  7. $config['1']['dbname'] = 'discuz';// 数据库
  8. $config['1']['tablepre'] = 'cdb_';// 表名前缀
复制代码
3)执行该升级升级,在浏览器输入如下地址:http://www.domain.com/install/update_qqconnect.php
4)选择您升级程序的版本,点击相应的链接进行升级操作,如下图所示:



注意:如果您是从 Discuz! 7.2 版本升级到 Discuz! X2.5 版本请选择【从 Discuz! 7.2 升级到 Discuz! X2.5,点击这里开始转换数据。】进行升级。
如果是从Discuz! X1.5 或 Discuz! X2 升级到 Discuz! X2.5 请选择【从 Discuz! X1.5 或 Discuz! X2.0 升级到 Discuz! X2.5,点击这里开始转换数据。】进行升级。

升级过程是自动的,您只要耐心等待升级完成即可。
升级完成后提示如下:



三、升级后的善后操作
1、使用创始人帐号登录,进入后台更新缓存。
2、删除 install/update.php 及 update_qqconnect.php 程序,以免给您的站点带来隐患。
3、管理员登录站点后台,更新缓存。步骤为:后台=>工具=>更新缓存。

至此 Discuz! X 系列任意版本到 Discuz! X2.5 正式版本升级完成!

在线体验:
由Discuz!专用主机商DZ动力提供的在线体验服务  http://www.verydz.com/freereg.php
推荐使用“DZ动力”提供的Discuz!专用主机

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x

评分

1

查看全部评分

发表于 2012-3-6 22:24:44 | 显示全部楼层
初学者,前来学习学习!!~~

点评

游客
Good  发表于 2012-10-4 17:51
游客
bbs.qcwxlt.com 前来支持  发表于 2012-10-1 21:34
游客
不错  发表于 2012-9-30 11:13
游客
ffffff  发表于 2012-9-16 20:50
游客
ji  发表于 2012-8-1 19:16
回复

使用道具 举报

发表于 2012-3-7 12:33:03 | 显示全部楼层
使用看看
回复

使用道具 举报

发表于 2012-3-7 17:01:12 | 显示全部楼层

支持,等待正式版!
回复

使用道具 举报

发表于 2012-3-8 01:01:54 | 显示全部楼层
占楼- =广告位

点评

游客
9 9  发表于 2012-5-5 01:28
回复

使用道具 举报

发表于 2012-3-8 21:05:12 | 显示全部楼层
老大,帮我看看是怎么回事,,,怎么出现这个呢

UC也是1.6的呀,最新的

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x

点评

游客
好強喔(拍手  发表于 2012-5-5 01:29
回复

使用道具 举报

发表于 2012-3-9 07:21:57 | 显示全部楼层
很有帮助的 一手教你一样
回复

使用道具 举报

头像被屏蔽
发表于 2012-3-18 05:05:49 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
回复

使用道具 举报

发表于 2012-3-19 14:59:43 | 显示全部楼层
obush 发表于 2012-3-8 21:05
老大,帮我看看是怎么回事,,,怎么出现这个呢

UC也是1.6的呀,最新的

我遇到过这个问题  我的解决方式是:进网站后台管理,选择不关闭站点,然后再进行网站系统升级。升级前系统会自动帮你把网站给关闭。如果我们事先就关闭了网站然后进行升级,就会出现这样的错误
回复

使用道具 举报

发表于 2012-3-19 20:09:30 | 显示全部楼层
振★兴 发表于 2012-3-19 14:59
我遇到过这个问题  我的解决方式是:进网站后台管理,选择不关闭站点,然后再进行网站系统升级。升级前系 ...

谢谢啊,,,非常感谢
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|Comsenz ( 粤B2-20090059-165 )star

GMT+8, 2019-7-17 02:48

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表